Mac下Laravel命令错误dyld: Library not loaded: /usr/local/opt/icu4c/lib/libicui18n.63.dylib

2019-04-22 02:56:16   Mac

MAC下laravel执行php artisan serv发生错误如下

php artisan serv

dyld: Library not loaded: /usr/local/opt/icu4c/lib/libicui18n.63.dylib
  Referenced from: /usr/local/bin/php
  Reason: image not found
[1]    55973 abort      php artisan serv

具体的解决办法是执行下面的命令

brew switch icu4c 63.1

当然,你的电脑里面可能没有这个63.1,试试其他版本,比如我在切换到62.1时失败,提示如下:

brew switch icu4c 62.1
Error: icu4c does not have a version "62.1" in the Cellar.
icu4c installed versions: 63.1, 64.2

就是我电脑安装了 63.1, 64.2 所以这里我需要执行brew switch icu4c 63.1。所以根据你的提示把已安装的都试一下,一般换成低版本就好了。

vien.tech版权所有,允许转载,但转载请注明出处和原文链接: https://vien.tech/article/153
欢迎小伙伴们在下方评论区留言 ~ O(∩_∩)O
文章对我有帮助, 点此请博主吃包辣条 ~ O(∩_∩)O

猜你喜欢


评论

There are no comments yet.
未登录

登录后即可发表评论

登录或注册